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1 PRESENTATION OF GiD

1

This chapter will introduce the user to the user-interface and graphic environment of GiD.

GiD is a general purpose pre-postprocessor for computer analysis.

All the data, geometry and mesh generation can be performed inside. Also, the visualization of all types 

of results can be performed.

It can be adapted to a specific analysis module by the creation of a 'problem type'.

Typical problems that can be successfully tackled with GiD include most situations in solid and structural 

mechanics, fluid dynamics, electromagnetics, heat transfer, geomechanics, etc. using finite element, 

finite volume, boundary element, finite difference or point based (meshless) numerical procedures.

1.1 User interface

Upon opening GiD, the following window appears on the screen:
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To change the configuration of toolbars and menus, use the toolbars option, located in 

Utilities->Tools->Toolbars.

1.2 Top menu

The Top Menu offers various types of commands.

It is important to note that these options will differ depending on the whether the user is performing a 

preprocessing or postprocessing analysis, and that the options needed in each case differ as well.

Two possible configurations of the Top Menu are presented below:

And in the postprocessing phase:

These two options will be presented in more detail later.

Next, each drop-down menu in the Top Menu will be described in detail.

1.2.1 Files-Pre

Two main types of functions can be controlled in this menu: 1) the handling of files (i.e. create, read, 

save, etc.) of GiD projects;and, 2) the importing and exporting of files.
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1.2.2 View

In the view menu (also available from the mouse menu) there are all the visualization commands. These 

commands change the way to display the information in the graphical window, but they do not change 

any definition of the geometry or any other data.
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1.2.3 Geometry

Geometry permits the user to create, delete, edit and model geometry.
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1.2.4 Utilities.Pre

In the Utilities  menu, GiD  allows the user to define preferences or perform operations on both the 

geometry and the mesh entities.
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1.2.5 Data

This menu allows access to the definition of all data related to materials, boundary conditions, etc., 

which will be necessary for the calculations that follow. The form of this data will depend on the type of 

the analysis to be performed.
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1.2.6 Mesh

Mesh permits the user to generate and edit the mesh, as well as to select mesh creation preferences.
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1.2.7 Calculate

This command calculates the problem, according to the type of problem defined. This option requires a 

previously activated interface between GiD and the corresponding calculation program.

1.2.8 Help

This menu permits the user to obtain different types of help and information about GiD.
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1.2.9 Files

GID PostProcess

This Top Menu of the postprocess phase is the same of that as the preprocess phase and has the 

same name. The user can read and save files, save screen images, return to preprocess phase options 

and exit the program.
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1.2.10 Utilities

In the postprocess phase, the Utilities command permits the user to obtain information about entities.
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1.2.11 Do cuts

With the option Do cuts the user can make cuts through entities.
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1.2.12 View results

This option permits the user to choose the viewing type in which the results of the postprocess 

calculation will be presented.
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1.2.13 Options

Options  permit the user to make choices related to the presentation of results: for example, color 

changes, number of result subdivisions, etc.
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1.2.14 Postprocess windows
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1.3 Toolbars

Option Utilities->Tools->Toolbars...  opens a window where it's possible to configure the toolbars 

position or switch them on and off.

Geometry and View operations

(preprocess)

Standard toolbar
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Geometry and View operations

(postprocess)

1.4 Mouse menu

The Mouse Menu is the auxiliary menu which appears by clicking on the right mouse button while the 

cursor is over the GiD screen.

The Mouse Menu permits the user to quickly access various image placement and viewing commands, 

to facilitate easy management and definition of the project.

Furthermore, the Mouse Menu contains the Contextual menu, which permits the user to access to all 

options available in previously performed commands. The option Contextual is only available after the 

user has performed a command from the Top Menu.
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1.5 Command line

The Command Line  option allows the user to directly enter all executable GiD  commands, without 

accessing the commands through drop-down menus.

These commands should be written following the order which GiD would use to define them, according 

to the Right buttons menus.

A side comment in reference to the Command Line: GiD  does not distinguish between the use of 

capital and small letters. In addition, in cases where ambiguities do not exist, commands need not be 

written in entire words, but can be written with the primary characters of each word.
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With this example, the user is introduced to the basic tools for the creation of geometric entities and 

mesh generation.

2.1 First steps

Before presenting all the possibilities that GiD  offers, we will present a simple example that will 

introduce and familiarize the user with the GiD program.

The example will develop a finite element problem in one of its principal phases, the preprocess, and will 

include the consequent data and parameter description of the problem. This example introduces 

creation, manipulation and meshing of the geometrical entities used in GiD.

First, we will create a line and the mesh corresponding to the line. Next, we will save the project and it 

will be described in the  GiD  data base form. Starting from this line, we will create a square surface, 

which will be meshed to obtain a surface mesh. Finally, we will use this surface to create a cubic 

volume, from which a volume mesh can then be generated.

2.2 Creation and meshing of a line

We will begin the example creating a line by defining its origin and end points, points 1 and 2 in the 

following figure, whose coordinates are (0,0,0) and (10,0,0) respectively.

It is important to note that in creating and working with geometric entities, GiD  follows the following 

hierarchical order: point, line, surface, and volume. 
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To begin working with the program, open GiD, and a new GiD project is created automatically. 

From this new database, we will first generate points 1 and 2.

Next, we will create points 1 and 2. To do this, we will use an Auxiliary Window that will allow us to 

simply describe the points by entering coordinates. It is accessed by the following sequence: 

Utilities->Tools->Coordinates Window

Then, from the Top Menu, select GeometryCreatePoint

In the coordinate window opened previously, the following indicated steps should be used:

And create point 2 in the same way, introducing its coordinates in the Coordinates Window. 

The last step in the creation of the points, as well as any other command, is to press Escape, either via 

the Escape button on the keyboard or by pressing the central mouse button. Select Close to close the 

Coordinates Window. 

Now, we will create the line that joins the two points. Choose from the Top Menu : 

Geometry->Create->Straight line. Option in the Toolbar shown below can also be used. 

Next, the origin point of the line must be defined. In the Mouse Menu, opened by clicking the right 

mouse button, select Contextual->Join C-a.
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NOTE: With option Join, a point already created can be selected on the screen. The command No Join 

is used to create a new point that has the coordinates of the point that is selected on the screen. We 

can see that the cursor changes form for the Join and No Join commands. 

Now, choose on the screen the first point, and then the second, which define the line. Finally, press 

Escape to indicate that the creation of the line is completed. 

NOTE: It is important to note that the Contextual submenu in the Mouse Menu will always offer the 

options of the command that is currently being used. In this case, the corresponding submenu for line 

creation, has the following options: 

 Once the geometry has been created, we can proceed to the line meshing. In this example, this 

operation will be presented in the simplest and most automatic way that GiD      permits. To do this, from 

the Top Menu select: Mesh->Generate mesh. 

And an Auxiliary Window appears, in which the size of the elements should be defined by the user. 

NOTE: The size of an element with two nodes is the length of the element. For, surfaces or volumes, 

the size is the mean length of the edge of the element. 

In this example, the size of the element is defined in concordance with the length of the line, chosen for 

this case as size 1.
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Automatically GiD  generates a mesh for the line. The finite element mesh is presented on the screen in 

a green color. 

The mesh is formed by ten linear elements of two nodes. To see the numbering of the nodes and mesh 

elements, select from the Mouse Menu: LabelAll, and the numbering for the 10 elements and 11 nodes 

will be shown, as below. 

 Once the mesh has been generated, the project should be saved. To save the example select from the 

Top Menu: FilesSave.

The program automatically saves the file if it already has a name. If it is the first time the file has been 

saved, the user is asked to assign a name. For this, an Auxiliary Window      will appear which permits 

the user to browse the computer disk drive and select the location in which to save the file. Once the 

desired directory has been selected, the name for the actual project can be entered in the space titled 

File Name. 

NOTE: Next, the manner in which GiD saves the information of a project will be explained. GiD creates 



23Creation and meshing of a line

a directory with a name chosen by the user, and whose file extension is .gid. GiD creates a set of files 

in this directory where all the information generated in the present example is saved. All the files have 

the same name of the directory to which they belong, but with different extensions. These files should 

have the name that GiD designates and should not be changed manually. 

Each time the user selects option save  the database will be rewritten with the new information or 

changes made to the project, always maintaining the same name. 

To exit GiD, simply choose FilesQuit.

To access the example, ejemplo.gid, simply open GiD and select from the Top Menu: FilesOpen. An 

Auxiliary Window will appear which allows the user to access and open the directory iniciación.gid. 

2.3 Creation and meshing of a surface

We will now continue with the creation and meshing of a surface.

First, we will create a second line between points 1 and 3. 

We will now generate the second line. We will now use again the Coordinates Window to enter the 

points. (Utilities->ToolsCoordinates-> Window) 

Select the line creation tool in the toolbar. Enter point (0,10,0) in the Coordinates Window and click 

Apply. 
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With option Join   (Contextual mouse menu) click over point 1. A line should be created between 

(0,10,0) and (0,0,0). Press Escape. 

With this, a right angle of the square has been defined. If the user wants to view everything that has 

been created to this point, the image can be centered on the screen by choosing in the Mouse Menu: 

Zoom->Frame. This option is also available in the toolbar. Finish the square by creating point (10,10,0) 

and the lines that join this point with points 2 and 3. 

Now, we will create the surface that these four lines define. To do this, access the create surface 

command by choosing: Geometry->Create->NURBS surface->By contour. This option is also 

available in the toolbar: 

GiD then asks the user to define the 4 lines that describe the contour of the surface. Select the lines 

using the cursor on the screen, either by choosing them one by one or selecting them all with a window. 

Next, press Escape. 

As can be seen below, the new surface is created and appears as a smaller, magenta-colored square 

drawn inside the original four lines.

Once the surface has been created, the mesh can be created in the same way as was done for the line. 

From the Top Menu select: Mesh->Generate mesh.

An Auxiliary Window appears which asks for the maximum size of the element, in this example defined 
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as 1. 

We can see that the lines containing elements of two nodes have not been meshed. Rather the mesh 

generated over the surface consists of planes of three-nodded, triangular elements.

 NOTE: GiD meshes by default the entity of highest order with which it is working. 

GiD allows the user to concentrate elements in specified geometry zones. Next, a brief example will be 

presented in which the elements are concentrated in the top right corner of the square. 

This operation is realized by assigning a smaller element size to the point in this zone than for the rest of 

the mesh. Select the following sequence: Mesh->Unstructured->Assign sizes on points. The 

following dialog box appears, in which the user can define the size: 

We must now regenerate the mesh, canceling the mesh generated earlier, and we obtain the following:
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As can be seen in the figure above, the elements are concentrated around the chosen point. Various 

possibilities exist for controlling the evolution of the element size, which will be presented later in the 

manual.

  To generate a surface mesh in which the elements are presented uniformly, the user can select the 

option for a structured mesh. This guarantees that the same number of elements appears around a 

node and that the element size is as uniform as possible. To generate this type of mesh, choose: 

Mesh->Structured->Surfaces.

Using this command, the user should first select the 4-sided NURBS surface that will be defined by the 

mesh. Then, the number of subdivisions for the surface limit lines should be entered. Pairs of lines 

define the partitions in the following way: 

 NOTE: GiD only generates structured meshes for surfaces of the type 4-sided surface or NURBS 

surface. 

When this has been done, the mesh is generated in the same way as the unstructured mesh, by 
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choosing Mesh->Generate mesh.

Assign a general element size of 1, though in this case it is not necessary.

We can see here that the default element type used by GiD  to create a structured mesh is a square 

element of four nodes rather than a three-nodded, triangular element. To obtain triangular elements, the 

user can specifically define this type of element, by choosing Mesh->Element type->Triangle, and 

selecting the surface to mesh as a triangular element. Regenerate the mesh, and the following figure is 

obtained: 

GiD also allows the user to concentrate elements in structured meshes. This can be done by selecting 

Mesh->Structured->Lines->Concentrate elements

First, we must select the lines that need to be assigned an element concentration weight. The value of 
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